Wiki‎ > ‎

SCM-ADF

posted Apr 26, 2017, 12:24 PM by Dong Xu   [ updated Apr 26, 2017, 2:09 PM ]
https://www.scm.com/doc/Installation/Linux_Quickstart_Guide.html

ADF2017 uses VTK7 and newer OpenGL features to dramatically speed up the visualization of large systems. This comes with a higher requirement for the OpenGL version supported by the system: OpenGL 3.2. If your machine does not support this, you might get the following error message when starting the GUI:

Warning: In /home/builder/jenkins/workspace/trunk/label/centos6_impi_lxc/VTK/Rendering/OpenGL2/vtkOpenGLRenderWindow.cxx, line 647
vtkXOpenGLRenderWindow (0x7b93c40): VTK is designed to work with OpenGL version 3.2 but it appears it has been given a context that does not support 3.2. VTK will run in a compatibility mode designed to work with earlier versions of OpenGL but some features may not work.

In such cases, a fallback mode is available that lowers the OpenGL requirement to version 1.4, but this fallback mode of course does not have the performance benefits of the newer OpenGL features. To enable the fallback mode, set the SCM_OpenGL1_FALLBACK environment variable to something non-zero:

export SCM_OpenGL1_FALLBACK=1
adfinput &

Comments